We have implemented the fix for this issue. There are still some jobs being processed, and the system will catch up in a few hours. The team will continue to monitor the jobs.
Posted Feb 24, 2026 - 11:35 CST
Identified
We are experiencing some slowness with updates to channels (Airbnb, Vrbo, Booking.com), which includes changes to rates and other operations. The Engineering team has identified the root cause of the issue, and are currently working on the fix. Other Track services are functioning normally.
Posted Feb 24, 2026 - 10:31 CST
Investigating
We are experiencing a Track production issue. Some channel operations are currently being delayed. This may prevent some customers from getting certain updates including status, rates, incident review, etc. We have our internal team actively working this issue and will update our status as soon as we have identified a solution or 30 minutes have passed.
Posted Feb 24, 2026 - 10:29 CST
This incident affected: TrackPMS (Property Management System).