TrackPMS Timeouts

Incident Report for TravelNet Solutions Status

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 21:02 CDT

Monitoring

A fix has been implemented and we are seeing recoveries now. The team is continuing to monitor.
Posted Apr 15, 2026 - 20:51 CDT

Identified

We are experiencing timeouts for TrackPMS. The Engineering team is currently investigating issue and working on a fix.
Posted Apr 15, 2026 - 20:44 CDT
This incident affected: TrackPMS (Property Management System), TrackPulse (Contact Center), and TrackPayments.